51牛股网 公式指标 通达信公式 大智慧公式 同花顺公式 飞狐公式 股票资讯 进阶学堂 炒股入门 公式使用技巧 免责声明

经典macd指标公式—均衡绿柱数

来源:指标公式网(www.51niugu.cn) | 时间:2020-09-15 21:34:58 | 作者:指标公式网
龙头战法

  在股市中关于MACD指标的使用或者是编制的股票公式是有很多的,当然也具有不同的功能,比如是红绿柱、金叉、死叉、均衡、随行等等,都是投资者在实战中研究的重点内容,今天我们就着重讲解一下均衡与绿柱数的公式源码。

  Macd中最基础的就是两条线:diff与dea,它们之间形成的源码公式如下:

  //均衡与随行源码

  DRAWGBKLAST(C>0,STRIP(RGB(145,145,185),RGB(140,140,180),1));

  N1:=10; N2:=22; M:=7.5;

  DIF:(EMA(C,N1)-EMA(C,N2))/(1+EMA(ABS(C),512))*7.5,COLOR0000FF;

  DEA:EMA(DIF,M),COLOR09FFFF;

  MACD:=2*(DIF-DEA),COLORSTICK;

  PARTLINE(DIF,DIF>=REF(DIF,1),RGB(250,0,0),DIF<ref(dif,1),rgb(0,0,250)),linethick1;< p="">

  均衡:SMA(DIF,4,2),Color00FF00,LINETHICK1;

  随行:IF(MACD< 0,MACD,0),ColorFFFFFF,LINETHICK1;

  D2:=MACD;

  STICKLINE(D20,0,D2,5,0),Color979700;

  STICKLINE(D20,0,D2,4,0),ColorB5B500;

  STICKLINE(D20,0,D2,3,0),ColorD2D200;//兰

  STICKLINE(D2

  STICKLINE(D2

  STICKLINE(D2

  STICKLINE(D2>REF(D2,1)AND D2,0,D2,5,0),Color97004B;

  STICKLINE(D2>REF(D2,1)AND D2,0,D2,4,0),ColorB5005A;

  STICKLINE(D2>REF(D2,1)AND D2,0,D2,3,0),ColorD20069;//紫

  STICKLINE(D2>REF(D2,1)AND D2>0,0,D2,5,0),Color970097;

  STICKLINE(D2>REF(D2,1)AND D2>0,0,D2,4,0),ColorB500B5;

  STICKLINE(D2>REF(D2,1)AND D2>0,0,D2,3,0),ColorD200D2;//粉

  //绿柱数

  VAR1:=(EMA(C,N1)-REF(EMA(C,N1),1))/REF(EMA(C,N1),1);

  VAR2:=(EMA(C,N2)-REF(EMA(C,N2),1))/REF(EMA(C,N2),1);

  STICKLINE(VAR1>=VAR2 AND VAR2>0 AND C>EMA(C,N2),0,MACD,5,1),COLOR000066;

  STICKLINE(VAR1>=VAR2 AND VAR2>0 AND C>EMA(C,N2),0,MACD,4,1),COLOR000077;

  STICKLINE(VAR1>=VAR2 AND VAR2>0 AND C>EMA(C,N2),0,MACD,3,1),COLOR000099;

  A:=MACD>0;

  绿柱数:=BARSLAST(A)=5;

  STICKLINE(绿柱数>REF(D2,1)AND 绿柱数>=0,0,D2,5,0),COLOR00AA00;

  STICKLINE(绿柱数>REF(D2,1)AND 绿柱数>=0,0,D2,4,0),COLOR00CC00;

  STICKLINE(绿柱数>REF(D2,1)AND 绿柱数>=0,0,D2,3,0),COLOR00EE00;//绿柱

  OSC:=100*(CLOSE-MA(CLOSE,11.5));

  MAOSC:=EMA(OSC,4.5);

  STICKLINE(MACD

  STICKLINE(MACD>REF(MACD,1)AND CROSS(OSC,MAOSC),0,MACD,5,0),COLOR09FFFF;

  在了解以上的基本源码之后,投资者需要做的就是将第一部分均衡与随行的源码导入到相应的软件中,观察其中的指标变化:

  

均衡与随行


  将绿柱数相关的代码加入软件中获得的图形走势如下:

  

绿柱数


  当然不同的指标代码会显示出不同的图形走势,因为这些指标的源码是可以进行编制或者修改的,投资者可以在学会一定的指标编译原理之后,在进行修改,比如是macd绿区掉头的源码:

  SHORT:=12;

  LONG:=26;

  M:=9;

  N:=30;

  DIFF : EMA(CLOSE,SHORT) - EMA(CLOSE,LONG);

  DEA : EMA(DIFF,M);

  MACD : 2*(DIFF-DEA);

  MACDBUY1 : IF(REF(MACD,1)>LLV(MACD,N),0,1);

  MACDBUY2 : IF(CLOSE>MA(CLOSE,25),1,0);

  MACDBUY3 : IF(MA(CLOSE,99)>CLOSE,1,0);

  MACDBUY4 : IF(MACD<0,1,0);

  MACDBUY:MACDBUY1+MACDBUY2+MACDBUY3+MACDBUY4;

  导入之后的图形显示如下:

  

macd绿区掉头


  以上就是本文讲解的关于macd指标中的均衡与绿柱数的相关源码介绍以及源码编写的的方法和图形显示

本文地址:经典macd指标公式—均衡绿柱数

上一篇:极品kdj公式+变色抄底公式源码

下一篇:Macd变色背离形态金叉买入指标源码

版权声明:

1、本网站发布的公式文章《经典macd指标公式—均衡绿柱数》为51牛股网注册网友原创或整理,版权归原作者所有,转载请注明出处!

2、本网站公式/文章《经典macd指标公式—均衡绿柱数》均出自网络,所有提供下载的软件和资源均为软件或程序作者提供和网友推荐收集整理而来,仅供学习和研究使用。如有侵犯你的版权,本站将立即改正,同时要求用户在24小时内删除

3、本网站一直无私为全国广大股友提供指标公式、股票文章,免费分享。对于不当转载或引用本网内容而引起的民事纷争、行政处理或其他损失,本网不承担责任。